[Bioperl-l] Re:StandAloneBlast troubles

Hilmar Lapp hilmarl@yahoo.com
Thu, 23 Aug 2001 13:20:02 +0200

nick holton wrote:
> Hi all,
> I also tried to use standaloneblast on windows98 and it didn't work. I set
> the BLASTDIR to the right place, and it still comes out with the "Blast
> program not found or not executable" warning. So I went hacking, it seems to
> be having a problem with this statement:
>   return (-e Bio::Root::IO->catfile($BLASTDIR, 'blastall'));
> but makes it through if you get it to check if blastall is there like this:
>   return (-e $BLASTDIR, 'blastall');
> I tried installing File::Spec to overcome this, but it didn't help.
> Then there seems to be a problem in that it doesn't write the "blast.report"
> file. At this point I decided that it would probably be quicker to check
> with the list to see if anyone has actually got standaloneblast.pm to work
> on windows. Anyone got it working on windows?

So this seems to be a Win32-specific bug. Which version of bioperl
(and Blast) are you using? I have to admit that presently no-one
of the core developers is developing in a Win32 environment, so if
anyone who is is willing to take on this and debug what's going
wrong, he/she would be very welcome.

Hilmar Lapp                              email: hilmarl@yahoo.com
A-1120 Vienna