Compiling EMBOSS 2.4.1 on Mac OS X

Naofumi Kagami naofumi at
Tue Jul 30 15:34:50 UTC 2002

Hi Jason,

I just solved that one today. I think that the problem lies with Stuffit 

If you look into EMBOSS-2.4.1/doc/programs/html after expanding the 
archive, you will notice that the file 
'alignment_differences_group.html' is missing the final 'l' in '.html'. 
The makefile is looking for '`alignment_differences_group.html' but only 
finds '`alignment_differences_group.htm', so it sends out an error and 
quits. At least that's what I'm guessing. I'm no UNIX expert myself :-). 
I am guessing that Stuffit Expander is choking on long filenames (the 
legacy of Classic) since the truncation is occurring after the 30th 

After adding the final 'l' to the filename, do a make once more. You'll 
find other errors that have to be solved in the same way. After doing 
this several times, make should finish without errors. Then you can make 

Hope this works for you.

Naofumi Kagami

On 2002.07.30, at 00:07, Jason Curole wrote:

> .  I run configure and that also seem to run okay.
> I then make and it runs for a while but eventually bombs out on the 
> error
> make[3]: *** No rule to make target `alignment_differences_group.html',.
> The last few lines of terminal text prior to the fail are pasted in 
> below.
> I appreciate any help anyone could provide.
> Thanks, Jason
> Making install in wormpep
> make[3]: Nothing to be done for `install-exec-am'.
> /bin/sh ../../mkinstalldirs /usr/local/share/EMBOSS/test/wormpep
> mkdir /usr/local/share/EMBOS

More information about the EMBOSS mailing list