Different path for acd file

Peter Rice pmr at ebi.ac.uk
Thu Oct 7 10:49:56 UTC 2004

Raoul Jean Pierre Bonnal wrote:
> hi,
> I have compiled and installed cvs emboss siute.
> I've packged my application for debian, so my acd file is under 
> /usr/share/myapp/acd/myapp.acd

This is indeed a problem. EMBOSS will look in one directory for ACD files - 
normally the share/EMBOSS/acd directory under the install directory.

You can define another location using environment variables ... but that would 
be for *all* EMBOSS applications.

EMBASSY applications (mse, topo, phylip, end so on) are built under 
embassy/mse but installed in the same directories as EMBOSS.

> acd emboss file are installed in
> /usr/share/EMBOSS/acd
> when I run my application, the program looks for myapp.acd under
> /usr/share/EMBOSS/acd and then exit with Error: File
> /usr/share/EMBOSS/acd/myapp.acd line 0: ACD file not opened
> I have tried to use into the main of myapp
> embInitP("myapp", argc, argv, "/usr/share/myapp");
> without success. I thought embInitP function would have dynamically
> modified the standard settings (ref. AJAX_FIXED_ROOT).

embInitP will not modify the standard settings ... and I don't really like a 
fixed path in the code :-)

You can use (csh and tcsh):

setenv EMBOSS_ACDROOT /usr/share/myapp/acd/

... but that redefines the location for all ACD files.

> Is there a solution?
> If I copy myapp.acd in /usr/share/EMBOSS/acd myapp runs correctly.

That is the solution we would recommend.

We could find ways to code around it and offer an alternative directory to 
search ... but it would slow down all other applications, and you can expect 
problems with finding data files if too many directories have to be searched.

More information about the emboss-dev mailing list