[Bioperl-l] newbie wants install help

hari jayaram harijay at gmail.com
Fri Aug 10 17:09:32 UTC 2007

Hey all ,
Thanks for your help. Its working real well now.

Turns out I had not set my PERL5LIB environment variable correctly and it
was not finding the installed modules (thanks Sendu)

So the steps I followed were
1) Install CPAN as myself as detailed
Importantly the line which tells CPAN what prefix to use for all module
PREFIX=~/perl5lib/ LIB=~/perl5lib/lib INSTALLMAN1DIR=~/perl5lib/man1

2) Set the Perl5LIB to /home/perl5lib/lib ( and not just /home/perl5lib) in
the shell . I use cshell so I edited .cshrc
setenv PERL5LIB /home/hari/perl5lib/lib
setenv MANPATH ${MANPATH}:/home/hari/perl5lib

3) Updated the system CPAN to latest version - this woked very well once the
perl5lib was installed ..only it took a while and sometimes stalled with
messages like done 31/34  But a CTRL C , got it going again

4) Made sure I was using the new CPAN v1.9102

5) Installed Bioperl with command
install S/SE/SENDU/bioperl-1.5.2_102.tar.gz

AND I was good to go..

I am thinking I will screencast this process for everyones benefit and put
it up on bioscreencast.com . If that will be useful for others.
Thanks to everyone on the group. Now the journey begins

Hari Jayaram

On 8/10/07, Sendu Bala <bix at sendu.me.uk> wrote:
> hari jayaram wrote:
> > Hi Sendu ,
> Hi, please post back to the list as well, so others can benefit.
> > Well after going through a few attempts at installing Bundle::CPAN I
> > gave up.
> > It always had weird timeout issues . ANd kept re-installing everything
> > on restarting the CPAN shell
> > After a while I thought it did complete - since it retunred me to the
> >
> > I tried the CPAN install of bioperl at that point
> >
> > ANd bingo I got booted out at the exact same point when the Bioperl
> > install tried to re-install(?) Module:Build which failed as non root
> Did you follow steps 7 and 8 of
> http://www.dcc.fc.up.pt/~pbrandao/aulas/0203/AR/modules_inst_cpan.html ?
> If you managed to install Bundle::CPAN, when you now run 'cpan' it
> should start up and tell you its version number, which should be v1.9102
> or higher. If its lower, you didn't manage to install the latest CPAN,
> or you haven't managed to tell Perl where your newly installed modules
> > I guess for all future modules I will adopt the option 3 you detailed ,
> > i.e just have the modules sitting somewhere and use them from there
> >
> > But I am still interested in getting it done right via CPAN.

More information about the Bioperl-l mailing list