[Bioperl-l] error using standaloneblast through webserver, part II

Alicia Amadoz Alicia.Amadoz at uv.es
Tue Aug 7 08:20:12 UTC 2007

Hi again, i'm trying to run a bioperl script in linux with
standaloneblast from a webserver but i now have another error. It is the

[blastall] WARNING: Unable to open outfile_allseq.nin
[blastall] WARNING: 101: Unable to open outfile_allseq.nin

------------- EXCEPTION: Bio::Root::Exception -------------
MSG: blastall call crashed: 256 /usr/local/blast-2.2.16/bin/blastall -d
 "/outfile_allseq"  -e  10  -i 
/tmp//alicia_2007_07_20/result_search_alicia_12_03_40.fasta  -o 
/tmp//alicia_2007_08_07/101_result_Local_Blast_alicia_09_56_47.out  -p 

My perl code is the following:

my $blastdatadir = $ARGV[9]; -> Here the value of the variable is ok

	$ENV{PATH} .= ':/usr/local/blast-2.2.16/bin'; # path where blastall bin
is located
	$ENV{BLASTDIR} = '/usr/local/blast-2.2.16/bin'; # path where blastall
bin is located
	$ENV{BLASTDATADIR} = $blastdatadir; # path where formated local
databases are located -> Here the value is empty

I have tried without BEGIN { } so $ENV var has a correct value for
$blastdatadir but i get the same error. I have checked that formatdb was
done and all the files are correct.

Any idea or help to solve this problem? 

Thanks in advance. Regards,

More information about the Bioperl-l mailing list