[EMBOSS] Jemboss/EMBOSS can't find the external clustalw binary

Nigel Binns n.binns at ed.ac.uk
Thu Aug 12 08:17:23 UTC 2010

  Hi Peter,

Many thanks for your reply. I have ClustalW v2 installed (v2.0.12 - the 
latest release). The binary is named clustalw2. However, as I understand 
it, when running the Jemboss installation script, you are asked to 
provide the root directory that contains the clustalw binary rather than 
the name of the actual binary i.e /path/to/clustal/root/ rather than 
/path/to/clustal/root/clustalw2 or have I got that wrong?

The same issue applies to my installation of Primer3 ( latest release - 
3-2.2.2-beta). The binary name is primer3_core. I get this error when I 
try to run eprimer3.

Error   application terminated

     Died: eprimer3 uses external program 'primer3_core' which is not in 
the PATH or defined as EMBOSS_PRIMER3_CORE
          Part of the 'primer3' package, version 3.0, available from the
          Whitehead Institute. See: http://primer3.sourceforge.net/

Please can you tell me what file I should set the EMBOSS_CLUSTALW and 
EMBOSS_PRIMER3_CORE variables in.

Many thanks for your help.


On 11/08/2010 16:02, Peter wrote:
> On Wed, Aug 11, 2010 at 2:31 PM, Nigel Binns<n.binns at ed.ac.uk>  wrote:
>>   Hi All,
>> Please can anyone tell me why my installation of Jemboss (EMBOSS v6.3.1
>> patch v1-4) can't find the external clustal binary and how to correct this.
>> When I run a multiple sequence alignment using emma, I get the following
>> output:
>> Died: emma uses external program 'clustalw' which is not in the PATH or
>> defined as EMBOSS_CLUSTALW
>> I can confirm that my jemboss.properties file
>> ($EMBOSS_ROOT/share/EMBOSS/jemboss/resource/jemboss.properties) correctly
>> points to the root directories of the clustalw and primer3 binaries e.g.:
>> embossPath=/path/to/clustal:/path/to/primer3
> Have you got clustalw 1.x or 2.x installed? The binary names differ,
> clustalw.exe versus clustalw2.exe (no extension on Unix/Linux), and
> perhaps EMBOSS only expects the former?
> Have you tried setting the EMBOSS_CLUSTALW variable?
> Peter

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

More information about the EMBOSS mailing list