[EMBOSS] Jemboss/EMBOSS can't find the external clustalw binary

Peter biopython at maubp.freeserve.co.uk
Wed Aug 11 15:02:40 UTC 2010

On Wed, Aug 11, 2010 at 2:31 PM, Nigel Binns <n.binns at ed.ac.uk> wrote:
>  Hi All,
> Please can anyone tell me why my installation of Jemboss (EMBOSS v6.3.1
> patch v1-4) can't find the external clustal binary and how to correct this.
> When I run a multiple sequence alignment using emma, I get the following
> output:
> Died: emma uses external program 'clustalw' which is not in the PATH or
> defined as EMBOSS_CLUSTALW
> I can confirm that my jemboss.properties file
> ($EMBOSS_ROOT/share/EMBOSS/jemboss/resource/jemboss.properties) correctly
> points to the root directories of the clustalw and primer3 binaries e.g.:
> embossPath=/path/to/clustal:/path/to/primer3

Have you got clustalw 1.x or 2.x installed? The binary names differ,
clustalw.exe versus clustalw2.exe (no extension on Unix/Linux), and
perhaps EMBOSS only expects the former?

Have you tried setting the EMBOSS_CLUSTALW variable?


More information about the EMBOSS mailing list