[EMBOSS] sequence retrieval

Jay jboddu at uiuc.edu
Tue Jun 10 20:15:35 UTC 2008

I tried seqret in different ways.
My problem is EMBOSS is not recognizing my master sequence file (which is in
fasta form) as my private database. Even after I did the indexing using
When seqret is asking me to input sequence(s), I am not able to figure out
what exactly it accepts.
I tried dbname:ID, dbname:@listfile.
I also tried a crude way of copy pasting my master file and listfile in
"embl" folder in EMBOSSwin folder and try the same syntax (embl:ID,
embl:@listfile etc.
These did not work.
I am assuming that my master file is not being recognized as a private DB.
I wanted to define my database in .embossrc file. I could not figure this
out either.

-----Original Message-----
From: Daniel Barker [mailto:db60 at st-andrews.ac.uk] 
Sent: Tuesday, June 10, 2008 1:50 PM
To: rls at ebi.ac.uk
Cc: Peter Rice; Jay; emboss at lists.open-bio.org
Subject: Re: [EMBOSS] sequence retrieval

Dear Jay,

Are you simply trying to extract specific sequences from a Fasta-format
file? The EMBOSS program to do it is seqret, or maybe seqretsplit:



As Peter Rice suggests, you can do stuff to speed the access up, but
it'll work without that.

Best regards,


Daniel Barker
The University of St Andrews is a charity registered in Scotland :
No SC013532

University of St Andrews Webmail: https://webmail.st-andrews.ac.uk

More information about the EMBOSS mailing list