[EMBOSS] Problems converting sequences with seqret

James Sinnott sinnottj at cs.man.ac.uk
Mon Jan 26 15:24:33 UTC 2004


I'm building an application that should allow the user to work with a set of 
sequences in an arbitrary format (e.g. FastA) regardless of the formats the 
sequences may actually be stored in (clustal, nexus, msf, etc.)  I need to be 
able to convert sequences to and back-from the users' desired format behind 
the scenes, and seqret seems to be the most suitable tool for this.

However, I've found a problem in that seqret seems to output some sequence 
formats that it cannot subsequently re-read!  

As an example, I converted a set of FastaA files into clustal, phylip, msf, & 
nexus formats and then tried to re-convert the files back into FastA format.  
The clustal & phylip files all worked OK, but several of the msf and all of 
the nexus files were found to be unreadable by seqret when trying to 
re-convert them.

Am I doing anything wrong? Is this a common issue with seqret?

Any help would be gratefully accepted!

Best regards,

James Sinnott.

More information about the EMBOSS mailing list