[DAS] Setting up DAS with ensembl plugin

Thomas Down td2 at sanger.ac.uk
Sat Aug 7 08:26:12 EDT 2004

Hi Jithesh,

On 7 Aug 2004, at 12:47, Jithesh M K wrote:

> Hi all,
> I am a newbie in this field. I would like to set up a DAS server with  
> the ensembl plugin. I have tried configuring it but in vain. This is  
> what I have tried.
> I downloaded the dazzle-1.00 source from the site and compiled it  
> using the ant utility. It gave me errors in the file  
> AbstractDataSource.java telling about the MatchType. So I used the  
> DazzleDataSource.MatchType to remove this error. I got the jar file  
> using the ant compile then.

Where did you download the source from?  Official place to get it is:


(I'd also recommend that you use version 1.01 instead, although off the  
top of my head I can't think of any 1.00 -> 1.01 changes which are  
likely to be significant in this case).

What errors did you see when compiling?  And what changes did you make  
to get it to compile?

It would also be helpful to know some details about your system  
configuration.  What operating system are you using?  Which release of  
Java (if you're not sure, try "java -version").

> I got only one datasource ID test and the tss was giving errors.
> 2004-08-03 15:57:51 Couldn't initialize datasource tss
> org.biojava.servlets.dazzle.datasource.DataSourceException:  
> java.lang.IllegalAccessError: tried to access field  
> org.biojava.servlets.dazzle.datasource.GFFAnnotationSource.REGION_PATTE 
> RN from class  
> org.biojava.servlets.dazzle.datasource.GFFAnnotationSource$Handler

That's an extremely strange error to see, since if there *were* an  
illegal access of that field, it should be caught at compile time, not  
runtime.  If I had to guess, I'd say that this was the result of using  
a Java compiler which doesn't handle nested classes (sometimes called  
inner classes) quite right.

Which compiler are you using?


More information about the DAS mailing list