[Bioperl-l] Question on Tree : Last common ancestor / Internal Nodes

Sendu Bala bix at sendu.me.uk
Wed Jan 10 09:37:26 UTC 2007

Himanshu Ardawatia wrote:
> Hi,
> I am using version 1.4 . With this version, I run the script (the one 
> you sent) and get the following error:
> Use of uninitialized value in pattern match (m//) at tree.pl line 7.
> -------------------- WARNING ---------------------
> MSG: Must provide a valid array reference for -nodes
> ---------------------------------------------------
> Can't call method "id" on an undefined value at tree.pl line 9.
> I then installed version 1.5.2. With this vesion I get the following error:

What error?

> And I get the same error as above .

You probably didn't install 1.5.2 properly. Either you're actually still 
using 1.4, or when 1.5.2 was installed not all of 1.4 was first removed. 
  Check your version number ( 
), locate and manually delete your 1.4 installation and try the 1.5.2 
installation again.

> Which method should I use : 'id()' or 'internal_id()' . I get the same 
> error using any of the methods.

The internal id is something Bioperl makes up for itself, so you almost 
certainly don't want it. Use id().

More information about the Bioperl-l mailing list