[Bioperl-l] bioperl-network t/IO_psi.t random failure

Brian Osborne osborne1 at optonline.net
Mon Sep 25 18:54:13 UTC 2006


Hmm. I can't replicate that. If I do:

~/bioperl-network>repeat 50 perl -I. -w t/IO_psi.t

The tests run successfully, no errors. However I do see that the method call
before line 88 in IO_psi.t is:

@rts = $g1->articulation_points;

If you comment that line out does this intermittent bug disappear? I bet it

Jarkko Hietaniemi and I worked through a number of bugs in Graph that I
supplied to him but one we were not able to solve was an intermittent bug
with articulation_points(). If you construct networks where each node
corresponds to some "simple" object (and the module I used was Digest::MD5,
an arbitrary choice) the articulation_points method works well, all the
time. However if each node in the network is a Bio::Seq object then
articulation_points starts to stall, or hiccup. It remains a mystery...

Brian O.

On 9/25/06 12:04 PM, "Sendu Bala" <bix at sendu.me.uk> wrote:

> When I run perl -w t/IO_psi.t under linux I usually get all ok, but when
> repeatedly running the test script over and over in quick succession
> sometimes this will happen:
> ok 1
> [...]
> ok 19
> Can't locate object method "proteins" via package
> "Bio::Network::Node=HASH(0x1a9ae10)" (perhaps you forgot to load
> "Bio::Network::Node=HASH(0x1a9ae10)"?) at t/IO_psi.t line 88.
> ok 20 # skip Missing dependencies. Skipping tests
> ok 21 # skip Missing dependencies. Skipping tests
> I have no idea what that's about. Ideas?
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

More information about the Bioperl-l mailing list