[Bioperl-l] HELP: script cannot find primer3, which has been properly installed

zhihua li lzhtom at hotmail.com
Mon Sep 25 03:46:28 UTC 2006

hi, netters

i installed primer3_1.0b and bioperl-run-1.4 following the instructions. 
the source of primer3 executables is in 

then i tried the script in the documentation for bio::tool::run::primer3

use Bio::Tools::Run::Primer3;
use Bio::SeqIO;

  my $seqio = Bio::SeqIO->new(-file=>'input.1');
  my $seq = $seqio->next_seq;
  my $primer3 = Bio::Tools::Run::Primer3->new(-seq => $seq,
                                              -outfile => "temp.out",
                                              -path => 
$primer3->add_targets('PRIMER_MIN_TM'=>56, 'PRIMER_MAX_TM'=>90);
my $results = $primer3->run;

but when i ran it, there was an error message saying that primer3 couldn't 
be found.

i'm pretty sure primer3 has been properly installed. 'cause when i went to 
the source directory /home/zz/setup/primer3_1.0b/src/, i could run the 
program there using:


why couldn't the perl script find primer3?

thanks a lot!

More information about the Bioperl-l mailing list