[Bioperl-l] problem with installation of Bioperl1.4 on Windows XPPC using ActivePerl PPM

Chris Fields cjfields at uiuc.edu
Fri Sep 22 21:54:11 UTC 2006

> > ERROR: Installing File-Spec-0.82 would downgrade File::Spec from version
> > 3.12 to 0.82 and File::Spec::Functions from version 1.3 to 1.1 and
> > File::Spec::Mac from version 1.4 to 1.2 and File::Spec::OS2 from version
> 1.2
> > to 1.1 and File::Spec::Unix from version 1.5 to 1.2 and File::Spec::VMS
> from
> > version 1.4 to 1.1 and File::Spec::Win32 from version 1.6 to 1.2
> >
> > I think this comes from the various versioning requirements for those
> > modules, which probably arise from the v 1.4 Makefile.PL.  The new
> version
> > doesn't have those requirements but a few others are present.  When a
> new
> > PPM is made we probably need to take that into consideration.
> Not sure I understand :o(

I think PPM4 has stricter requirements that previous versions, so if a
version is stipulated in the PPD file, then it will try to install it,
regardless on whether a newer version is available.  I think this is bad bad
bad on ActiveState's part.  Grr....  

Due to this alone I would recommend not having any versioning requirements
in ppd files until this gets sorted out.  

I did manage to get everything installed and working, though.  I haven't
tried Perl 5.6.1 myself.

> > If you download the free MS Visual C++ Express Edition, it comes with a
> much
> > newer version of nmake:
> >
> > G:\Program Files\Microsoft Visual Studio 8\VC>nmake -help
> >
> > Microsoft (R) Program Maintenance Utility Version 8.00.50727.42
> > ...
> >
> > It's available here:
> >
> > http://msdn.microsoft.com/vstudio/express/
> >
> > That may resolve the issue.
> Thanks - I'll give it a try! I did download the Borland compilier v5.5 (i
> think) and I didn't seem to have much luck with that either - I may have
> become delierious by then though!

I think the Makefile generated using 'perl Makefile.PL' only works with
nmake.  I tried regular gnu-make and it doesn't work either.  

> > The critical issue is that of binary compatibility between 5.6.1 and the
> > various 5.8.x versions of perl.  However, there are no binary components
> for
> > Bioperl.  One could probably modify the ppd file to deal with both
> versions
> > (similar to the older ppd files in bioperl.org/DIST.
> There were several modules but can't remember which off hand. Some were
> not direct dependents of Bioperl, but dependencies of denpendencies! Most
> (i
> think) were because only 1 implementation tag was in the ppd file - for
> Perl 5.8 but non for 5.6. Most of these should be easy to rectify, but
> others
> may not be.
> I'll have another bash after the weekend!

I managed to get everything installed and working for Perl 5.8.8; I hate to
say it, but we may need to recommend Windows users install that version if
there are major problems with Perl 5.6.1.  The only tests that didn't work
were the ones that required bioperl-ext (which I can pretty much guarantee
won't work under native Windows conditions).  

Christopher Fields
Postdoctoral Researcher - Switzer Lab
Dept. of Biochemistry
University of Illinois Urbana-Champaign

More information about the Bioperl-l mailing list