[Bioperl-l] bioperl 1.4 SearchIO doesn't work parsing Blast output

Hubert Prielinger hubert.prielinger at gmx.at
Wed Feb 8 21:41:04 UTC 2006

hi chris,
thanks, I have upgraded to version 1.5.1 but it isn't still working, do 
you have any ohter idea, the problem I have is that I have to parse a 
lot of textfiles....
or shall I look for another option to parse those files...


Chris Fields wrote:

>My guess is you're running into text parsing problems in
>Bio::SearchIO::blast.  Upgrade to the latest developer version (1.5.1) or
>bioperl-live (CVS), then see the bug below. 
>I think the first problem you ran into is solved in bioperl 1.5.1, the last
>problem (more recent, not related to the first) has been fixed but hasn't
>been committed to bioperl-live yet.  The fixed SearchIO::blast is available
>in the link above, but realize it hasn't been committed yet and may change.
>Christopher Fields
>Postdoctoral Researcher - Switzer Lab
>Dept. of Biochemistry
>University of Illinois Urbana-Champaign  
>>-----Original Message-----
>>From: bioperl-l-bounces at lists.open-bio.org 
>>[mailto:bioperl-l-bounces at lists.open-bio.org] On Behalf Of 
>>Hubert Prielinger
>>Sent: Wednesday, February 08, 2006 2:52 PM
>>To: bioperl-l at bioperl.org
>>Subject: [Bioperl-l] bioperl 1.4 SearchIO doesn't work 
>>parsing Blast output
>>If I want to parse a Blast Output (Version 2.2.12) with 
>>Bio::SearchIO, I get the following error message:
>>MSG: no data for midline Query  1   WWWKWRW  7
>>STACK Bio::SearchIO::blast::next_result
>>STACK toplevel
>>is that a bug......
>>If I want to parse Blast Output (version 2.2.13), I don't get 
>>I'm using bioperl 1.4
>>before, I have installed bioperl 1.4, it worked fine parsing 
>>Blast Output (version 2.2.12), but I don't remember which 
>>bioperl version I had installed
>>thanks in advance
>>Bioperl-l mailing list
>>Bioperl-l at lists.open-bio.org

More information about the Bioperl-l mailing list