[Bioperl-l] Can't run bioperl from java

Oliver Wafzig Oliver.Wafzig at axaron.com
Mon Mar 22 05:44:59 EST 2004

Hi Julio,
if you are using one string (containing all your perl commandline args and 
whitespaces) to call 'runtime().exec()', try it using a string array. 
It might help.


On Monday 22 March 2004 10:08, mpjfb at usc.es wrote:
> Hello.
> I don't know if this is of topic but I have some problems trying to run
> Bioperl from Java.
> My problem comes as follows:
> I wrote a perl script tha perform multiple blast alignments and parses
> them. As this programs needs to be run in text mode (and it can be really
> painfull when you have to add many arguments) I decided to write a GUI
> using JAVA. When I run my perl script directly it works fine and if I run
> other perl scripts (that don't use bioperl) from the GUI everything works
> fine.
> Does anyone have any advice of what can be the problem???? I thought that
> it can be some error with my bioperl install (I move from OSX 10.1 to
> 10.3). Any help would be apprecited.
> thanks a lot, Julio
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at portal.open-bio.org
> http://portal.open-bio.org/mailman/listinfo/bioperl-l

More information about the Bioperl-l mailing list