[Bioperl-l] UniGene modules now in CVS
Thu, 02 May 2002 09:17:46 +0100
Lincoln Stein wrote:
> > which is somewhat redundant. A more generic way would be:
> > $io = Bio::ClusterIO::IO->new(-file=>'myfile',
> > -format=>'unigene');
> > $clu = $str->next();
> Yes, but Bio::SeqIO uses next_seq().
I know, but in my opinion it should be next(). Attaching the object type to
the method name is again that kind of redundancy, I'd like not to have.
Having a generic method name makes it easier to inherit and use the classes.
I've done this already in Bio::Variation::IO which inherits a lot from
Bio::SeqIO a but uses read() and write().
We could add read() and write() as an alternative to SeqIO so that all IO
classes could use the same method names.
______ _/ _/_____________________________________________________
_/ _/ http://www.ebi.ac.uk/mutations/
_/ _/ _/ Heikki Lehvaslaiho email@example.com
_/_/_/_/_/ EMBL Outstation, European Bioinformatics Institute
_/ _/ _/ Wellcome Trust Genome Campus, Hinxton
_/ _/ _/ Cambs. CB10 1SD, United Kingdom
_/ Phone: +44 (0)1223 494 644 FAX: +44 (0)1223 494 468