[Biojava-l] Possible minor change before 1.0

Matthew Pocock mrp@sanger.ac.uk
Fri, 30 Jun 2000 18:29:55 +0100

hilmar.lapp@pharma.novartis.com wrote:

> Apart from that, for me the point of naming it nextSequence() or just next() is
> merely a philosophical one. I personally would really prefer nextSequence(),
> because it very clearly says what it does. Others obviously think different. The
> point I wanted to make is, I do think that Philosophy-only driven changes must
> not be incompatible. The deprecation is a very good suggestion. You know, even
> in Java2 there are all the things still there that have already been deprecated
> since 1.1.
>      Hilmar

I have no strong views about next vs nextSequence. At the time, I thought that
nextSequence was more explicit. I understand that next is more normative. At the end
of the day, there are better things to have religeous wars over. I am a little
uneasy about puting depricated methods into interfaces, as it forces
legacy-entrenched implementations, but mabey backwards-compatibility is more
important than beauty. I would be keen to see 1.0 as free from crap as possible.

The add-next&depricate-nextSequence rout will break all SequenceIterator
implementations, but the user-land code will carry on working. In a while's time, we
could remove the depricated method (not any time soon). Or - we can stay as we are.
It's your call folks.

> _______________________________________________
> Biojava-l mailing list  -  Biojava-l@biojava.org
> http://biojava.org/mailman/listinfo/biojava-l