[Biojava-l] Possible minor change before 1.0

hilmar.lapp@pharma.Novartis.com hilmar.lapp@pharma.Novartis.com
Fri, 30 Jun 2000 19:07:23 +0100

  b) We're still pre-1.0.  I'd quite like to see 1.0 land up with

Yes, that's right. But please don't just forget, that the idea of 1.0 has only
been a recent conception. There was something before, for instance, a statement
that the core sequence classes and interfaces are rock-solid, by the core
developer/maintainer. I relied on this, and I do have classes implementing the
iterator, but maybe I'm the only one.

     a set of core interfaces which are as cruft-free as possible,
     and those can then serve as a baseline for future evolution
     (with maximum effort made towards compatibility).

     But I'll go the deprecation route if enough people are already
     relying heavily on this interface.

You see, there's at least me, which is probably not what you mean by 'enough'.
Anyhow, introducing the suggested change may keep me from using the 1.0 release
for a while, because I simply don't have the time to propagate the changes. But
again, that's my personal problem.

Apart from that, for me the point of naming it nextSequence() or just next() is
merely a philosophical one. I personally would really prefer nextSequence(),
because it very clearly says what it does. Others obviously think different. The
point I wanted to make is, I do think that Philosophy-only driven changes must
not be incompatible. The deprecation is a very good suggestion. You know, even
in Java2 there are all the things still there that have already been deprecated
since 1.1.