[MOBY] [MOBY-l] registering Scored_string object...

Mark Wilkinson mwilkinson at mrl.ubc.ca
Tue Mar 30 16:46:03 UTC 2004


On Mon, 2004-03-29 at 12:39, Michael Jensen wrote:

> Starting with Ken's object registration example script, I put the 
> following together. On the ISA and HASA I am assuming below the first 
> value is what the tag is, like String, Object, or Long, unless it is a 
> ISA, then it is just what type it is. Then I assume the second value is 
> what the articleName is, and can be blank if there is none.

No need to assume - it's in the POD documentation:

        Title     :    registerObject ; registerObjectClass
        Usage     :    $REG = $MOBY->registerObject(%args)
        Usage     :    $REG = $MOBY->registerObjectClass(%args)
        Function  :    register a new type of MOBY Object
        Returns   :    MOBY::Registration object
        Args      :    objectType => "the name of the Object"
                       description => "a human-readable description of
the object"
                       contactEmail => "your at email.address"
                       authURI => "URI of the registrar of this object"
                       Relationships => {
                           relationshipType1 => [
                               [Object1, articleName],
                               [Object2, articleName]],
                           relationshipType2 => [
                               [Object1, articleName]]}


> Is this correct? Will what I have below register the object for the XML 
> output above?

I believe so, yes.  That should work just fine!

I wonder if perhaps you could change the name from "Scored_String" to
something a bit more proprietary?  "Inblosam_Scored_String", or
something like that?  Only because it isn't a universally common
data-type, and it has a component that might be unexpected (the acronym
component) based on a human-readable name "Scored_String", so this might
confuse people.  At the end of the day, the name of an object is
~irrelevant, and we shouldn't interpret them, but of course, we all do
:-)


>      input        => [ ['', ["text-plain" => []]], ],
>      output       => [ ['', [["Scored_string" => []]]], ],
>      category     => "moby",
>      serviceType  => "Retrieval",
>    );

that looks correct (by eye).  

> I am not sure the "text-plain" is right for the input either, but all I 
> expect is something like this.

You could register your input as "String", since there doesn't seem to
be any implicit limitation on the type/structure of String that you
consume... but I think "text-plain" is probably a better choice if you
want to weed-out most of the single-word inputs, which are more likely
to be carried in String objects than in text-plain objects (we hope!)

> Thanks for all your help with all of my questions!!

Good luck with this!  It is really quite a cool service - I'm wondering
if you might be able to add some value to this by outputting Xref's
inside of your Scored_String object.  Since you obviously have some
knowledge of the identity of the protein (since you found it!), you
could perhaps Xref it's SwissProt, or gi number or something like that. 
This would allow us to take free-text, pass it to your service, and
automatically retrieve e.g. the genbank record for all of the proteins
described therein, since I have already written the services that do
this kind of retrieval...

M

-- 
Mark Wilkinson (mwilkinson at mrl.ubc.ca)
University of British Columbia iCAPTURE Centre



More information about the moby-l mailing list