[EMBOSS] PNG/GD graphics library issue whilst trying to install EMBOSS/Jemboss v6.3.1

Nigel Binns n.binns at ed.ac.uk
Fri Jun 3 14:45:22 UTC 2011

This solved the problem. After handling the dependencies associated with 
gd-devel-2.0.35-10.el6.x86_64.rpm, I'm in the process of running the 
Jemboss install script and this time all png/gd libraries were detected 
and compilation of EMBOSS has started.

Many thanks for all your help resolving this.


On 03/06/2011 14:42, Nigel Binns wrote:
> Hi Alan,
> Many thanks. gd-devel-2.0.35-10.el6.x86_64.rpm is indeed available in 
> the Optional Server channel. Our RHN subscription permits us to access 
> it. Hopefully this will solve the problem.
> Again, many thanks for your help. It is much appreciated.
> Best regards,
> Nigel
> On 03/06/2011 14:32, ajb at ebi.ac.uk wrote:
>> I believe that gd-devel for RHEL6 can be obtained by subscribing to 
>> their
>> 'optional' channel.
>> Unfamiliarity with RHEL prevents me from saying how that is done
>> but it could conceivably cost money.
>> HTH
>> Alan (on holiday so further replies unlikely until next week).
>>> Hi,
>>> I'm getting a warning message indicating that /usr/include/gd.h does 
>>> not
>>> exist on my system at the point in the Jemboss install script
>>> (install-jemboss-server.sh) that refers to the libpng and gd libraries.
>>> I confirmed that gd.h does not exist on our server with a system-wide
>>> search. I'm attempting to install EMBOSS/Jemboss v6.3.1 onto a server
>>> running Red Hat Enterprise Linux 6.0 Server 64-bit (fully patched). I
>>> have confirmed that I have the following relevant RPMs installed:
>>> libpng-1.2.44-1.el6.x86_64.rpm
>>> libpng-devel-1.2.44-1.el6.x86_64.rpm
>>> gd-2.0.35-10.el6.x86_64.rpm
>>> On our system, the following files are located in the indicated
>>> directories:
>>> /usr/include/png.h
>>> /usr/lib64/libpng.so (plus some other libpng files such as libpng12.so)
>>> /usr/lib64/libgd.so.2
>>> A search via our Red Hat Network subscription indicates that there are
>>> no other gd RPMs available, such as gd-devel.
>>> I've tried pointing the installation script at the /usr/lib64 directory
>>> using the --with-pngdriver flag when requested, but this leads to
>>> another warning saying that /usr/lib64/include/png.h does not exist.
>>> I appreciate that I could just compile and install the libpng and gd
>>> libraries from the two project's websites (in fact I've confirmed that
>>> gd.h is present in the gd-2.0.35.tar.gz distribution), however, I would
>>> prefer that Jemboss used the distro-provided libraries, as these 
>>> will be
>>> updated automatically via its package management system.
>>> Many thanks for your help.
>>> Nigel
>>> -- 
>>> The University of Edinburgh is a charitable body, registered in
>>> Scotland, with registration number SC005336.
>>> _______________________________________________
>>> EMBOSS mailing list
>>> EMBOSS at lists.open-bio.org
>>> http://lists.open-bio.org/mailman/listinfo/emboss

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

More information about the EMBOSS mailing list