[EMBOSS] Installing emboss ends with an error (OSX 10.6 macport 1.8.2 )

Tõnu Margus tmargus at ebc.ee
Wed Feb 10 16:07:19 UTC 2010


I tried to install emboss into my mac (OSX 10.6 snow leopard ) by using macport (1.8.2) but finished with an error. It seems to me that I tangled into missing library (probably libjpeg), but I am still not sure about it.  I used command "locate" to see which libjpeg libraries are installed and it seems that they are there.

 locate libjpeg

What I am missing, and how to overcome this probelme? 
The part of macport debug output is below.

% sudo port -d install emboss 

................ deleted ..............

make[3]: Nothing to be done for `all-am'.
/bin/sh ../libtool --tag=CC   --mode=link /usr/bin/gcc-4.2  -O2 -arch x86_64   -L/opt/local/lib -o aaindexextract aaindexextract.o ../nucleus/libnucleus.la ../ajax/libajaxg.la ../ajax/libajax.la ../plplot/libeplplot.la -lX11  -lm 
/bin/sh ../libtool --tag=CC   --mode=link /usr/bin/gcc-4.2  -O2 -arch x86_64   -L/opt/local/lib -o abiview abiview.o ../nucleus/libnucleus.la ../ajax/libajaxg.la ../ajax/libajax.la ../plplot/libeplplot.la -lX11  -lm 
/usr/bin/gcc-4.2 -O2 -arch x86_64 -o .libs/aaindexextract aaindexextract.o  -L/opt/local/lib ../nucleus/.libs/libnucleus.dylib ../ajax/.libs/libajaxg.dylib ../ajax/.libs/libajax.dylib ../plplot/.libs/libeplplot.dylib -lX11 -lm 
ld: library not found for -lX11
collect2: ld returned 1 exit status
/usr/bin/gcc-4.2 -O2 -arch x86_64 -o .libs/abiview abiview.o  -L/opt/local/lib ../nucleus/.libs/libnucleus.dylib ../ajax/.libs/libajaxg.dylib ../ajax/.libs/libajax.dylib ../plplot/.libs/libeplplot.dylib -lX11 -lm 
make[2]: *** [aaindexextract] Error 1
make[2]: *** Waiting for unfinished jobs....
ld: library not found for -lX11
collect2: ld returned 1 exit status
make[2]: *** [abiview] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_EMBOSS/work/EMBOSS-6.0.1" && /usr/bin/make -j2 all " returned error 2
DEBUG: Backtrace: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_EMBOSS/work/EMBOSS-6.0.1" && /usr/bin/make -j2 all " returned error 2
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for EMBOSS): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Best Regards,
Tõnu Margus

Department of bioinformatics
Tartu University 
Riia 23, 51010

tel: +372 737637
www: http://bioinfo.ut.ee/

More information about the EMBOSS mailing list