[EMBOSS] Question regarding 'showdb' in EMBOSS

pmr at ebi.ac.uk pmr at ebi.ac.uk
Wed Aug 23 15:14:40 UTC 2006

Hi Jean,

> We have a very hetergenous system which are composed of different
> platforms. They can all access a shared area where I installed EMBOSS 4.0.
> The databases are sync'd from area A (both read and writable) to area B
> (Readable but not writable). When I run 'showdb' on platform A which
> access databases in area A, I can see the output just fine without any
> strange message. However, when I run 'showdb' on platform B can access
> databases in area B, I saw
> % showdb
> Displays information on the currently available databases
> # Name         Type  ID  Qry All Comment
> # ============ ==== ==  === === =======
>   monthaa        P    OK  OK  OK  -
>   monthnt        N    OK  OK  OK  -
> EMBOSS An error in ajfile.c at line 1272:
> File close problem in fileClose


The error suggests that the fclose call returned an error. We do not trap
the exact error.

I will look into ways to get a better error report so we can see what the
problem is.

> I tried:
> % showdb -debug
> But saw the same thing as above without extra information:

-debug creates a file (showdb.dbg) with the debug report.

It would be helpful if you can send it to me.


Peter Rice

More information about the EMBOSS mailing list