Luke McCarthy lukem at gene.pbi.nrc.ca
Tue Aug 2 19:23:39 UTC 2005

On Sat, 2005-07-30 at 04:40, Andrew.Mather at dpi.vic.gov.au wrote:

> However for some apps (mainly seems to be alignment type ones like water, 
> needle, emma, but that may just be because I've tried more of them than 
> any others), it always fails
> Error: Unable to read sequence '&#39
> Died: water terminated: Bad value for &#39-asequence&#39 with -auto 
> defined
> water exited with status 1...

Do all of the applications that are failing require sequence input?  Do
all applications that require sequence input fail?  What version of
EMBOSS are you using (you can run embossversion from the GUI to get the

This is a really strange problem because sequence input isn't treated
any differently from other input.  Can you run applications that require
other input files that aren't sequences?  abiview, for example?

What is happening here is that there is no value being passed for the
'asequence' parameter.  When the input form is generated, it should be
generating a field for the 'asequence' parameter.  So, assuming you've
filled in that field before trying to submit the input form, this
shouldn't happen.

One thing that occurs to me is that the naming convention for sequence
parameters changed at some point (they used to be called
sequencea/sequenceb and are now called asequence/bsequence...)  Is it
possible that the GUI is finding older versions of the ACD files?  From
the error output, it's clear that the version of water being run is
looking for a parameter called 'asequence', but if the GUI read an old
version of the ACD file when it generated the input page and thinks the
parameter is called 'sequencea', maybe that's the problem?

You can look in the EMBOSS::GUI::Conf module (the install script will
have told you where it was installed to) and check the values of
$EMBOSS_PREFIX, $EMBOSS_BIN and $EMBOSS_ACDROOT to make sure it's using
the binaries and ACD files from the same EMBOSS version.

This is actually very unlikely, as the GUI looks at the ACD file when
it's building the command line, too.  So it would have to find one ACD
file when it was building the input form, and a different ACD file when
it tried to run the application.

> Some apps work fine, so  I'm guessing it's not a fundamental problem like 
> permissions on a temp directory or something.

No, if the temporary directory wasn't writable, all applications would

If your EMBOSS server is publicly accessible, email me (at
lukem at gene.pbi.nrc.ca) with the URL and I'll poke around and try to
figure out what's going on.  Cheers,


More information about the EMBOSS mailing list