A simple installation problem

YUK FAI LEUNG leungyukfai at hotmail.com
Thu Apr 17 01:35:26 UTC 2003

Hi there,

I have encountered the same installation problem that many others 
encountered before. I tried a few methods from the web and the emboss 
discussion group like adding the flag -L/X11R6/lib to the Makefile but they 
all didn't work.

I tried the installation in both the Redhat 8 & 9 in my laptop but the 
result is the same. Could anyone tell me how to get through this problem?


---Here is the error message----

/bin/sh ../libtool --mode=link gcc  -g -O2   -o aaindexextract  
aaindexextract.o ../nucleus/libnucleus.la ../ajax/libajaxg.la 
../ajax/libajax.la ../plplot/libplplot.la -lX11  -lm
gcc -g -O2 -o .libs/aaindexextract aaindexextract.o  
../nucleus/.libs/libnucleus.so ../ajax/.libs/libajaxg.so 
../ajax/.libs/libajax.so ../plplot/.libs/libplplot.so -lX11 -lm -Wl,--rpath 
/usr/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status

Add photos to your e-mail with MSN 8. Get 2 months FREE*.  

More information about the EMBOSS mailing list