[emboss-dev] Mapping EMBOSS to Ruby, Perl and Python
biopython at maubp.freeserve.co.uk
Tue Dec 1 12:02:21 UTC 2009
On Mon, Nov 30, 2009 at 11:57 AM, Pjotr Prins <pjotr.public78 at thebird.nl> wrote:
> The file emboss/function/emboss_transeq.c may get some extra
> interfaces - the idea is that is contains nicely named and direct
> methods (unlike the internal 'ajCamelCase' naming conventions).
Naming conventions and what is "nice" is a personal judgement.
Why change things? For anyone used to the EMBOSS code base,
it is very advantageous to preserve the old names in any interface.
I would also say it makes sense to keep the "aj" prefix - it acts
as a namespace, avoiding name collisions with internal names.
(an EMBOSS user and minor contributor)
More information about the emboss-dev