[BioRuby] Rename Bio::SPTR to Bio::UniProtKB, remove Bio::SwissProt and Bio::TrEMBL
ngoto at gen-info.osaka-u.ac.jp
Wed Jun 26 08:48:40 UTC 2013
I'd like to propose the following changes about UniProtKB parser,
Bio::SPTR and related classes.
* Rename Bio::SPTR to Bio::UniProtKB
* Because SPTR is not common abbreviation
* UniProtKB is the official name
* Change Bio::SPTR and Bio::UniProt to aliases of Bio::UniProtKB
* For keeping compatibility of existing programs.
* UniProtKB is the most famous database provided by UniProt.
* Remove Bio::SwissProt and Bio::TrEMBL
* Because of avoiding confusion. Excess aliases seems to be harmful.
* In the upcoming release, show warning messages when using them.
ngoto at gen-info.osaka-u.ac.jp / ng at bioruby.org
More information about the BioRuby