[BioRuby] [GSoC][NeXML and RDF API] Code Review.
ngoto at gen-info.osaka-u.ac.jp
Wed Jul 7 22:40:21 UTC 2010
> I think they are called character state matrices in the phylo terminology.
> But something like CharactersStateMatrices would be two long. What about
> CharacterMatrices or StateMatrices? Perhaps Rutger can help me here.
It is generally bad thing to abbreviate only because it is too long.
Modifying the upstream original names might be a source of confusion.
In this case, using CharactersStateMatrices as is is the best. If the
name is expected to be frequently used by library users, short name
could also be added.
However, as Pjotr already mentioned, the class might not be needed,
depending on the design of classes.
Sorry for late response.
ngoto at gen-info.osaka-u.ac.jp / ngoto at bioruby.org
More information about the BioRuby