[Biopython-dev] 1.62b test coverage report

Ben Fulton ben at benfulton.net
Fri Aug 2 02:20:49 UTC 2013

My test machine was running Ubuntu 12.04.

For fasttree I installed version 2.1.4-1~ubuntu12.04.1 using apt-get, and
got this error:
ApplicationError: Command 'fasttree -out temp_test.tree
Quality/example.fasta' returned non-zero exit status 1, 'Unknown or
incorrect use of option -out'

The NCBI_BLAST error involves rpsblast not being in the install. Version
2.2.25-7 using apt-get.

Dialign is version 2.2.1-5 using apt-get. I got two errors: first,
DIALIGN2_DIR not being set. It was installed to /usr/bin so I set
DIALIGN2_DIR to that directory; then I got "Environment variable
DIALIGN2_DIR directory missing BLOSUM file." I'm not sure either of these
items are needed, though I may have missed them in the documentation.

I downloaded version 130708 of Prank from
http://code.google.com/p/prank-msa/downloads/list. The error is on line 165
of the test file:

 PRANK v.130708:

Input for the analysis
 - converting 'Quality/example.fasta' to 'temp with space.phy'

EmbossPhylipNew I tried to install from source, but it was complicated and
I didn't get it finished.

I'll send some notes on the other errors when I get a few minutes.

On Thu, Aug 1, 2013 at 4:04 PM, Eric Talevich <eric.talevich at gmail.com>wrote:

> On Wed, Jul 31, 2013 at 12:40 AM, Peter Cock <p.j.a.cock at googlemail.com>wrote:
>> On Wednesday, July 31, 2013, Ben Fulton wrote:
>> > I ran Ned Batchelder's coverage tool against the 1.62 beta code to see
>> how
>> > much code is covered by tests. The overall total was 74% which is pretty
>> > respectable.
>> >
>> > I ran the tests on a fairly fresh machine, which meant I had to install
>> a
>> > lot of software, some of which I either didn't get installed properly,
>> or
>> > the tests are out of date, or there were failures for some other
>> reason. I
>> > ended up having to skip seven test files:
>> >
>> > Dialign_Tool
>> > EmbossPhylipNew
>> > Mafft
>> > PopGen_DFDist
>> > PopGen_FDist
>> > XXMotif
>> > phyml
>> I'm pretty sure I have some or all of those setup on at least one
>> of my test machines, so with a little more work together we
>> can try to resolve those (which may mean updating the docs).
> I just fixed the error in test_phyml_tool.py, it was a simple one:
> https://github.com/biopython/biopython/commit/90da547f0a85c00d3ca300bdf52bdb96ddeb449f
> > There were three tests I managed to get running but still had failures:
>> >
>> > FastTree
>> > Prank_too
> The FastTree test is not based on the unittest framework, so the output
> contains the word "Failed" in three places to describe error-handling tests
> that worked correctly. Can we see the output for this one? (It works on my
> machine.)
> The test is also fairly new, so there could be some version-compatibility
> issues there too.
> Thanks,
> Eric

More information about the Biopython-dev mailing list