[Biopython-dev] [Bug 2880] Two unit tests issues in 1.51b (t-coffee and mafft)

bugzilla-daemon at portal.open-bio.org bugzilla-daemon at portal.open-bio.org
Sat Jul 18 18:21:09 UTC 2009


------- Comment #3 from biopython-bugzilla at maubp.freeserve.co.uk  2009-07-18 14:21 EST -------
It looks like the T-Coffee test just hung? Could you try this in the Tests
directory to confirm this:

python run_tests.py test_TCoffee_tool.py

Could you also try just running T-Coffee directly:


In my machine this prints out some stuff, and finishes. This it what seems to
be hanging on your machine...

I'm thinking that instead of calling "t_coffee" we could instead use "t_coffee
-version" which finishes much more quickly. So could you also try:

t_coffee -version

I was using T-Coffee 7.81 on Linux and things worked. Even this is out of date,
so I tried the latest version too, 7.97, and again it all looks fine.


Regarding MAFFT, what actually fails when you do this?:

run_tests.py test_Mafft_tool.py

I note you have MAFFT v6.240. I have MAFFT v6.626b and the test passes. Again,
this is also out of date. Could you try updating your copy of MAFFT?

Configure bugmail: http://bugzilla.open-bio.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the Biopython-dev mailing list