[Biopython-dev] [Bug 2734] db.load problem with postgresql and psycopg2

bugzilla-daemon at portal.open-bio.org bugzilla-daemon at portal.open-bio.org
Fri Jan 16 10:24:16 UTC 2009


------- Comment #1 from biopython-bugzilla at maubp.freeserve.co.uk  2009-01-16 05:24 EST -------
Hi Stephen,

Does this happen for all the files you've tried, or just one or two?  If its
the later it may be something funny about the file and how its been parsed. 
I'm guessing you downloaded the GenBank files from
ftp://ftp.ncbi.nih.gov/genbank/ so could you tell us one which is failing.

Have you tried running the Biopython unit tests - in particular the two for
BioSQL?  I presume you installed Biopython from source on your Mac, so you
should have all the files present.  You'll need to edit the file
Tests/setup_BioSQL.py to point to a suitable postgresql test database.

P.S. As you are using Bio.SeqIO to parse the GenBank file, you don't need to
import Bio.GenBank (first line of code snippet).

Configure bugmail: http://bugzilla.open-bio.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the Biopython-dev mailing list