chris.lasher at gmail.com
Wed Mar 7 04:00:01 UTC 2007
On 3/6/07, Peter <biopython-dev at maubp.freeserve.co.uk> wrote:
> Only Michiel has replied, so I assume there are no other strong views on
> the dev mailing list.
If you're still soliciting opinions, here's mine: I am really fond of
the SeqIO.parse function, rather than SeqIO.read, since read is a
builtin function. Different namespaces, but parse is unambiguous.
For remaining function/method names, I would really prefer to stick to
the PEP 8 style guide, which specifies:
> Function Names
> Function names should be lowercase, with words separated by underscores
> as necessary to improve readability.
> mixedCase is allowed only in contexts where that's already the
> prevailing style (e.g. threading.py), to retain backwards compatibility.
e.g., to_dict() instead of toDict().
Thanks again for the work on SeqIO!
More information about the Biopython-dev