[Bioperl-l] Installation problem

Rajasimha, Harsha (NIH/NEI) [C] rajasimhah at nei.nih.gov
Wed Oct 12 16:07:03 UTC 2011

I am trying to install Bioperl since yesterday without any luck. 
I have tried exact same instructions for multiple ways of installing from the bioperl wiki - but no luck.
I am attaching errors encountered during one such attempt below. Please help. 

root at comp1z BioPerl-1.6.1]# perl Build.PL
This package requires Module::Build v0.2805 or greater to install itself.
Base class package "Module::Build" is empty.
    (Perhaps you need to 'use' the module which defines that package first.)
 at (eval 2) line 1
BEGIN failed--compilation aborted at (eval 2) line 1.
BEGIN failed--compilation aborted at Bio/Root/Build.pm line 83.
Compilation failed in require at Build.PL line 14.
BEGIN failed--compilation aborted at Build.PL line 14.

I have tried installing Module::Build using CPAN, but that installation fails too due to dependencies (even though I say "yes" to all prepend dependencies questions during install).

Please help!!!
National Eye Institute, Bethesda, MD

More information about the Bioperl-l mailing list