[Bioperl-l] bp_genbank2gff.pl giving errors when using file....

Gowthaman Ramasamy gowthaman.ramasamy at sbri.org
Tue Jul 7 20:06:16 UTC 2009

Hi Scott,
Thanks for the mail. Its funny. Knowing you (at GMOD meeting) I wouldn't
mistake it in any other ways.

I was rushing back to email the list to tell I got it working. There is
NOTHING wrong with script. Its perfectly good. (not many scripts stands the
time. This one does).

Its the genbank record. Some of the genbank records I tried did produce that
error, while others did not. I'll dig into those files to see if anything is
obvious (to my eyes) that causes this error.

PS1: I tried changing the name, and that did NOT solve the problem.

Thanks once again,

On 7/7/09 12:18 PM, "Scott Cain" <cain.cshl at gmail.com> wrote:

> Hi Gotham,
> I was going to send you an email to complain to the author, until I
> realized that it was me :-)
> It has been quite a while since I looked at the code for this script,
> as the one I typically use these days is bp_genbank2gff3.pl, but I
> think I have a "fix".  Try changing the name of the file to
> NC_004329.gb or .gbk or .genbank.  That is the (very weak) heuristic
> that the script uses to determine if a file is genbank formated versus
> embl (note that the error message says it's not an embl file--that's
> why).  If that doesn't do it, let me (and the mailing list) know.
> Scott
> PS: I wasn't really going to say to complain to the author directly--
> that was just me trying to be funny.
> PPS: As another side note, it is fairly funny to me that the code that
> this script depends upon, Bio::DB::GFF::Adaptor::biofetch, says in the
> documentation that it is proof-of-principle and should not be used in
> production.
> On Jul 7, 2009, at 1:59 PM, Gowthaman Ramasamy wrote:
>> Hi All,
>> I am trying to  use bp_genbank2gff.pl script to convert a locally
>> downloaded genbank file. It is throwing stack errors. But, the
>> script works beautifully when I use --accession option to download
>> and convert.
>> Any suggestions? Thanks very much for checking this.
>> the command i use:
>> perl bp_genbank2gff.pl --stdout --file NC_004329.nb
>> and i am getting the following exception message:
>> ------------- EXCEPTION: Bio::Root::Exception -------------
>> MSG: EMBL stream with no ID. Not embl in my book
>> STACK: Error::throw
>> STACK: Bio::Root::Root::throw /usr/lib/perl5/site_perl/5.8.5/Bio/
>> Root/Root.pm:359
>> STACK: Bio::SeqIO::embl::next_seq /usr/lib/perl5/site_perl/5.8.5/Bio/
>> SeqIO/embl.pm:189
>> STACK: Bio::DB::GFF::Adaptor::biofetch::load_from_file /usr/lib64/
>> perl5/site_perl/5.8.5/x86_64-linux-thread-multi/Bio/DB/GFF/Adaptor/
>> biofetch.pm:163
>> STACK: bp_genbank2gff.pl:274
>> -----------------------------------------------------------
>> Many thanks in advance,
>> Gowtham
>> _______________________________________________
>> Bioperl-l mailing list
>> Bioperl-l at lists.open-bio.org
>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
> -----------------------------------------------------------------------
> Scott Cain, Ph. D. scott at scottcain dot net
> GMOD Coordinator (http://gmod.org/) 216-392-3087
> Ontario Institute for Cancer Research

More information about the Bioperl-l mailing list