Steve's notes on Seq.pm
Steven E. Brenner
brenner@akamail.com
Fri, 7 Mar 1997 22:27:44 +0900 (JST)
Thanks for writing up all the notes!
> Perhaps we can kick
> these notes around and come up with a "MUST DO NOW" list of essentials that
> need to be fixed prior to the next version?
The essentials are things which either:
1) Are seriously broken (very very few)
2) Alter the interface (some)
> Personally, I feel that moving all ReadSeq stuff into a ReadSeq.pm would be
> worth the effort at this point.
Until we figure out how parsing and IO is going to be done, I would say
the interface isn't fixed. So, yes, this is very important.
> o Perhaps we need another option for sequence type
> that deals with alphabet stringency levels
> 1 Strict 1 Gap
> 2 Ambig 2 No-Gap (2,1) Set as default?
A third option would be "on" or "off"
> 3. Settle the "_nofile" or "undef" question
> in the constructor method
Georg agreed to _undef for Bio::UnivAln, so I think that makes sense here.
> 6. _file_read() is innefficient, just slurp file in with
> a giant READ
Inefficiency like this is ok for now, I think. But it should be fixed
very soon.
> 7. Resolve this conflict: names() currently will ADD the values
> of a passed in hash referance to the existing %names hash.
> However, the POD docs state that the method SETS (overwrites)
> the hash values. Which should it do?
Let's make it 'set'
> **13. DNA_to_RNA() should return a Bio::Seq object, not a
> string or array
>
> **14. translate() should return a Bio::Seq object, not a
> string or array
** Yes. :) (Why the **?)
> 17. rename seq_length() to seq_len()
> 18. rename ary() and str() to seq_ary() and seq_str()
Actually, I've changed my mind about this, and think it might be better to
leave it as-is. I can give my rationale if people care.