[Biojava-l] CVS compiling

Thomas Down td2@sanger.ac.uk
Thu, 23 Jan 2003 21:40:24 +0000

On Thu, Jan 23, 2003 at 03:38:45PM -0500, Simon Foote wrote:
> I've tried compiling a fresh checkout of biojava-live after my cvs 
> update compiling failed and it also failed.
> There appears to be errors in numerous programs. The majority are 
> relating to Sequence, see below for example:
>    [javac] Found 48 semantic errors compiling 
> "/usr/local/src/OpenBio/biojava-live-new/ant-build/src/main/org/biojava/bio/seq/ragbag/RagbagCachedSequence.java":
>    [javac]    154.   private Sequence instantiateSequence()
>    [javac]                   ^------^
>    [javac] *** Error: The type "org/biojava/bio/symbol/Sequence" has 
> default access and is not accessible here.

Do you have anything on your CLASSPATH?  If so, try removing
it then doing an `ant clean`.

I've just tried compiling, without any trouble.  There is not
now (and has never been) a class org.biojava.bio.symbol.Sequence
of *any* accessability, so I'm not sure where the compiler is
getting that idea...