[Biojava-l] Translation tables and Met

Keith James kdj@sanger.ac.uk
30 Aug 2001 10:18:28 +0100


>>>>> "Robin" == Emig, Robin <Robin.Emig@maxygen.com> writes:

    Robin> 1) I would call them by their full name, with possibly and
    Robin> underscore instead of a space. If that doesn't work (ie for
    Robin> multi organism tables) then I think we should add a
    Robin> SHORT_NAME, LONG_NAME and DESCRIPTION fields as xml tags or
    Robin> as parameters. In fact they may be useful anyway.  2) I say
    Robin> we add this to the xml file for translation table. add
    Robin> Extra tags like <TxInit>ATG</TxInit>. and
    Robin> <TxStop>TAG</TxStop> 3) Alternatively, we could create a
    Robin> separate file with this information as suggested, but also
    Robin> add other wonderful things that are involved in Translation
    Robin> (like readthroughs etc) 4) What about the idea of just
    Robin> creating a new object called CodonBiasTable, which has all
    Robin> of these ideas added, plus the frequency weights? It could
    Robin> be based off of an internal translation table, and
    Robin> distribution.

The current format of TranslationTables.xml is

<table name="UNIVERSAL" source="(RNA x RNA x RNA)" target="PROTEIN-TERM">
    <translate from="uuu" to="phe"/>

etc.

To get it all in one table as XML, how about

Genetic Code [4]
Mold, Protozoan, Coelenterate Mitochondrial and Mycoplasma/Spiroplasm:


<table number="4" source="(RNA x RNA x RNA)" target="PROTEIN-TERM">

    <!-- The genetic codes supported by this table. By using elements
         rather than a long string, these can be added to without
         breaking. Equivalent to the current NAME attribute -->
    <codes>
        <name>MOLD</name>
        <name>COELENTERATE_MITOCHONDRIAL</name>
        <name>MYCOPLASMA</name>
        <name>SPIROPLASM</name>
    </codes>

    <translations>
        <!-- same as current system -->
        <translate from="uuu" to="phe"/>

        <!-- same as current system, but indicates initiation codon -->
        <translate from="uua" to="leu" initiation="true"/>

        <!-- same as current system -->
        <translate from="uga" to="ter"/>
    </translations>

</table>

Internally there will still be two tables as TranslationTable knows
nothing about the context of the symbol it is asked to translate, so
it can't know whether you've given it a N-terminal codon or not.

I like the idea of a CodonBiasTable, but the fundamentals of
translation are not in place yet e.g. I can't sensibly translate a
prokaryote gene using BioJava. I would like to be able to do this
without the complexity of considering distributions, codon context
(e.g. for read-through) and so on. What I'm saying is, can we keep
them separate and not make something monolithic?

thoughts?

Keith

-- 

-= Keith James - kdj@sanger.ac.uk - http://www.sanger.ac.uk/Users/kdj =-
The Sanger Centre, Wellcome Trust Genome Campus, Hinxton, Cambs CB10 1SA