[Biojava-l] Possible minor change before 1.0

Thomas Down td2@sanger.ac.uk
Fri, 30 Jun 2000 17:21:36 +0100


One very tiny change I'd like to see before the freeze:

Would people object to me changing a method in SequenceIterator
as follows

  public Sequence nextSequence();

to

  public Sequence next();

This effectively just makes SequenceIterator a type-safe
Iterator.  It's a pattern I use quite often, and I always
find it easier just to use the next() method signature, rather
than calling it something else.

This change will break some code (especially things which
use the I/O framework), but it will always be an easy fix,
and it seems one of those things which is best to change now
rather than regret later.

Let me know if this is going to cause big problems, or if
you object to this (ab)use of the iterator pattern.

Thomas.
-- 
He looked up with big brown eyes.  ``They're really only
tiny little A-bombs, honest.''
                                     -- David Brin.