[Bioperl-l] Bio::Biblio doesn't find articles

Bruno Vecchi brunovecchi at yahoo.com.ar
Fri Aug 1 03:15:19 UTC 2008

Hi everyone,
I am trying to retrieve bibliographic data using Bio::Biblio, but so far 
I haven't got any luck.

The following code prints zero results whatever the keyword ("atom" in 
this example) you choose. Could anyone please point me to my mistake? 
There are no errors in the output, just no articles found.

# Beginning of script
#/usr/bin/perl -w
use strict;
use Bio::Biblio;

my $bib_obj = Bio::Biblio->new();

my $biblio_results = $bib_obj->find("atom");
print $biblio_results->get_count;
# End of script

Calling the Bio::Biblio constructor method without parameters sets them 
to default values, which are:

access: soap
location: 'http://www.ebi.ac.uk/openbqs/services/MedlineSRS'

I also tried using the example script at 
with the same result. For instance, trying:

biblio.PLS -find Java -find perl

Gave the following output:

Looking for 'Java'...    Found 0
Looking for 'perl'...    Found 0
Maybe the URL of the service is out of date?

Thanks a lot in advance!


More information about the Bioperl-l mailing list